前言

Github上找了个go程序,修改完跑不起来,就照错误提示,重装了 ca-certificates 也解决不了,原来还少了另外一个依赖,做个笔记。

提示现象

在跑go脚步时,一大堆信息中有这样报错提示:

1
fatal: unable to access 'https://gopkg.in/yaml.v3/': server certificate verification failed

解决办法

更新安装 ca-certificateslibgnutls30

1
apt update && apt install ca-certificates libgnutls30 -y

参考文档

fatal: unable to access ‘https://gopkg.in/yaml.v3/‘: server certificate verification failed